Report an issue

Found a bug you'd like to tell us about?
 

 Here’s what to do…Login, Select an ‘Issue Category’ from below and click on the "New Issues” button.

 Please note that support questions will not be handled here. If you need hands on technical support please take out a subscription.

#175 – Bug: unnecessary   inserted in source code

Posted in ‘ Ark Editor’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Saturday, 20 August 2016 00:54 BST
rubenreyes

On Design view, type a new line with words and spaces. For example if I type "Hello world! It is a beautiful day!" the source code will be:

<p>Hello world! It is a beautiful day!
</p>

Now, delete the spaces and type them again, enter words and spaces anywhere in the middle of the paragraph, the resulting code will have unnecessary &nbsp;

<p>Hello&nbsp;world!&nbsp;It&nbsp;is&nbsp;a&nbsp;beautiful&nbsp;day!
</p>

This is very problematic because &nbsp; entities do not wrap, and in the frontend words separated by &nbsp; are treated as a single word and won't break.

By the way, I just test this in the first line of this post and you can see the effect it can have when rendering in a narrow screen.

If there is only one space added between words it should be a simple space, not a &nbsp; entity. Even when entering multiple consecutives spaces, it should alternate simple spaces and &nbsp; entities.

Custom Fields
Server type
Linux
Web server type
Apache
ARK product version
1.8.4
Joomla! version
3.6.0
PHP Version
5.5.9
Web browser
Chrome
Errors log
Not applicable
Steps to replicate the issue
On Design view, type a new line with words and spaces. For example if I type "Hello world! It is a beautiful day!" the source code will be: Hello world! It is a beautiful day! Now, delete the spaces and type them again, enter words and spaces anywhere in the middle of the paragraph, the resulting code will have unnecessary   Hello world! It is a beautiful day! This is very problematic because   entities do not wrap.
Saturday, 20 August 2016 15:15 BST
rubenreyes

This is exactly the same problem I am experiencing:

https://dev.ckeditor.com/ticket/11415

Tuesday, 30 August 2016 12:19 BST
awills

http://arkextensions.com/technical-support/bug-unnecessary-nbsp-inserted-in-source-code#reply-3657

This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.
WebxSolution Ltd is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Copyright © 2009 - 2016 WebxSolution Ltd
Powered by JoomlaWired