Report an issue

Found a bug you'd like to tell us about?
 

 Here’s what to do…Login, Select an ‘Issue Category’ from below and click on the "New Issues” button.

 Please note that support questions will not be handled here. If you need hands on technical support please take out a subscription.

#200 – ArkEditor broken on IE10-Win7

Posted in ‘ Ark Editor’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Thursday, 02 February 2017 13:15 GMT
rubenreyes

We observed issues on Win7-IE10 while running ArkEditor 1.7.7, where the edits (keystrokes) would stop appearing in the design view.

We just uninstalled that version and installed 2.1 Pro from scratch. Now the editor won't open at all, and the following Javascript errors appear in the Console:

SCRIPT1047: In strict mode, function declarations cannot be nested inside a statement or block. They may only appear at the top level or directly inside a function body. 
plugin.js, line 6 character 5322
SCRIPT5007: Unable to get property 'icons' of undefined or null reference 
ckeditor.js, line 236 character 249

Please note that this issue does not occur in IE9 or IE11.

I was able to reproduce this error in Win10 with IE11 running as IE10.

Custom Fields
Server type
Linux
Web server type
Apache
ARK product version
2.1
Joomla! version
3.6.5
PHP Version
5.5.9
Web browser
IE10
Errors log
 
Steps to replicate the issue
We observed issues on Win7-IE10 while running ArkEditor 1.7.7, where the edits (keystrokes) would stop appearing in the design view. We just uninstalled that version and installed 2.1 Pro from scratch. Now the editor won't open at all, and the following Javascript errors appear in the Console: SCRIPT1047: In strict mode, function declarations cannot be nested inside a statement or block. They may only appear at the top level or directly inside a function body. plugin.js, line 6 character 5322 SCRIPT5007: Unable to get property 'icons' of undefined or null reference ckeditor.js, line 236 character 249 Please note that this issue does not occur in IE9 or IE11. I was able to reproduce this error in Win10 with IE11 running as IE10.
Attachment
Thursday, 09 February 2017 13:41 GMT
awills

Thanks for your report. This isue should now be fixed un the latest release.

Kindest Regards,

Andrew

WebxSolution Ltd is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Copyright © 2009 - 2016 WebxSolution Ltd
Powered by JoomlaWired