Report an issue

Found a bug you'd like to tell us about?
 

 Here’s what to do…Login, Select an ‘Issue Category’ from below and click on the "New Issues” button.

 Please note that support questions will not be handled here. If you need hands on technical support please take out a subscription.

Warning

JUser: :_load: Unable to load user with ID: 106

#29 – ArkEditor is causing sites sites to fail W3C HTML5 validation

Posted in ‘ Ark Editor’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Friday, 29 May 2015 08:30 BST
pkortge

Hi:

ArkEditor is causing sites sites to fail W3C HTML5 validation.

See example site validation <http://validator.w3.org/check?uri=http%3A%2F%2Fwww.atconveyancing.com.au%2Fcms%2F&charset=%28detect+automatically%29&doctype=Inline&group=0>.

Can this issue of "& probably should have been escaped as &amp;." be rectified so that sites don't fail HTML5 validation?

Thanks & regards ...

Custom Fields
Server type
Linux
Web server type
Apache
ARK product version
1.4.1
Joomla! version
3.4.1
PHP Version
5.4.38
Web browser
Safari
Errors log
 
Steps to replicate the issue
Ran site brought W3C validator at
Attachment
Friday, 29 May 2015 09:55 BST

Hi pkortge,

The HTML5 validator is incorrect, it is too generic so it's bringing up false positives. The HTML5 is still experimental. Please see: http://stackoverflow.com/questions/17374087/html5-ambiguous-ampersands-in-urls

That rule is not required for a URL link.

I hope this helps.

Kind Regards

Louisa

WebxSolution Ltd is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Copyright © 2009 - 2016 WebxSolution Ltd
Powered by JoomlaWired

 

Cron Job Starts