Report an issue

Found a bug you'd like to tell us about?
 

 Here’s what to do…Login, Select an ‘Issue Category’ from below and click on the "New Issues” button.

 Please note that support questions will not be handled here. If you need hands on technical support please take out a subscription.

#94 – Frontend Editing - Title Broken

Posted in ‘ Ark Editor’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Thursday, 26 November 2015 00:20 GMT
versacom

When attempting to use the frontend editing. The code seems to show on the website.

example: {div class="editable" data-id="97" data-context="article" data-type="title" data-itemtype="article"contenteditable="true"style="display:inline;"}Donecsagittis euismod

Custom Fields
Server type
Linux
Web server type
Apache
ARK product version
1.7.4
Joomla! version
3.4.5
PHP Version
 
Web browser
Chrome
Errors log
 
Steps to replicate the issue
Log into front end
Attachment
Thursday, 26 November 2015 09:48 GMT
awills
Hi versacom,
 
It seems you have something in your template or extension conflicting with inline editable titles. In this, it would be better to turn off this feature. You will still be able to edit the article text but not the title.
 
So, to do this you will have to go to System > Global Configuration > Ark Editor > Inline.
 
And on that screen switch of the 'Enable Editable Module Titles' option, and then save.
 
Kindest Regards,
 
Andrew
Thursday, 26 November 2015 22:42 GMT
versacom

Thank you, I have already attempted this fix, it still happens. I have narrowed it down to a function of TemplateMonster templates.

//Wrap Title words with Spans
function wrap_with_span($string){
  if(strpos($string, '||')){
    $string_delim_arr = explode('||', $string);
    $string = $string_delim_arr[0];
  }
  $string_array = explode(" ", $string); 
  $string_spans[] = "";
    foreach ($string_array as $key => $value) {
      $string_spans[] = '<span class="item_title_part' . $key . '">'.$value.'</span> ';
    }
  $wrapped_string = implode($string_spans);
  return  $wrapped_string;
  }

It is called on the title like so:

echo wrap_with_span($item->title);

I have modified the code temporarily to avoid this. But would be good to have fixed (if you feel it is an issue of yours).

WebxSolution Ltd is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Copyright © 2009 - 2016 WebxSolution Ltd
Powered by JoomlaWired