Report an issue

Found a bug you'd like to tell us about?
 

 Here’s what to do…Login, Select an ‘Issue Category’ from below and click on the "New Issues” button.

 Please note that support questions will not be handled here. If you need hands on technical support please take out a subscription.

#219 – Unable to upload images

Posted in ‘ Ark Media’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Friday, 19 May 2017 13:01 BST
aiswebadmin
  • Attempt to upload a simple jpg image in either front or back-end.
  • Receive error message: 'Illegal or invalid mime type detected.'
  • Tried on a number of sites - same issue.
  • Switched editor to TinyMCE and it works fine.

This has only been reported to me from my users since the Joomla 3.7.1 update.

Both Ark Editor and Ark Media are the latest available downloads.

Custom Fields
Server type
Linux
Web server type
Apache
ARK product version
Ark Media
Joomla! version
3.7.1
PHP Version
5.6.15
Web browser
Chrome
Errors log
Illegal or invalid mime type detected.
Steps to replicate the issue
Attempt to upload a simple jpg image in either front or back-end.
Friday, 19 May 2017 13:58 BST
paulc

Hi aiswebadmin,

Thank you for reporting this, we are aware of this issue and will be working to release a fix for this soon.

Until then please apply the following workaround:

  • Go to Ark Media's configuration page.
  • Go to the File Info tab.
  • Select the Custom Allowed File Types and add the following custom file types to fix the authentication error:
    • image/jpeg, jpeg, Images.
    • application/octet-stream, mp3, Audios.

Hopefully that will work till we can get a fix out for you.

Regards,

Paul

Friday, 19 May 2017 14:09 BST
aiswebadmin

Execllent.

That works perfectly.

Thank you for the quick reply.

Andrew

Monday, 22 May 2017 06:10 BST
paulc

No problem,

We'll update this ticket once we have a full fixed released.

Regards,

Paul

Wednesday, 31 May 2017 07:46 BST
paulc

Hi Andrew,

The upload issue should now be fully resolved with the latest Ark Media version 2.2.0.

Regards,

Paul

This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.
WebxSolution Ltd is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Copyright © 2009 - 2016 WebxSolution Ltd
Powered by JoomlaWired