HANDS ON Support

We are here to help from 09:00 to 17:00 London UK time from Monday to Friday.

 Note that a subscription is required to 'Ask a Question' in this forum. Please see: Hands on Technical Support.

Official support hour: Monday - Friday / 09:00 to 17:00 (GMT). Our local time is: 14:35:29
  1. folamour
  2. Ark Editor
  3. Wednesday, September 16 2020, 12:40 PM
  4.  Subscribe via email

Hi support, i moved from a very old release of Ark editor, and i'm a bit suprised because resizing the image in ark media browser seem no more work on Ark Editor, and also the hyperlink dont work, so i will open 2 separate thread for theses issues.

you can saw the problem here in this video capture, the image should be sized as 480x270 as asked but she's served without html sizing code

hope you can help,

https://www.crashdebug.fr /media/Docs/resize_image.mp4

Thanks,

 

 

 

 

folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 1
Paul C Accepted Answer Pending Moderation
Support
0
Votes
Undo

Hi folamour,

Thank you for your ticket and the helpful video showing the error.

We logged into your site and made the following observations:

  • The English part of the site has a fatal error preventing any sort of interaction with the administrator section (see attached screenshot 2020-09-17-imagesize-01.png)
  • Accessing via the default language (French) worked okay.
  • When opening the Ark Media there was numerous Internal Server Error notifications, plus a Javascript error with the caching extension on your website (see attached screenshot 2020-09-17-imagesize-02.png and 2020-09-17-imagesize-03.png), which could well be the cause of other issues you are experiencing.
  • Inserting images successfully allowed us to change their width & height style values (see attached video 2020-09-17-imagesize.mp4)

Because there are so many other issues with your site and the fact that you may still be developing on it (as mentioned here https://arkextensions.com/technical-support/6333-need-to-stuck-text-in-arkeditor-to-have-the-article-diplayed-correctly#reply-6344), I would recommend doing a site audit first, as it appears that there is something causing a large number of errors on the site (possibly the caching system?). This will help determine the root cause of the issues and may actually fix all the other issues once it is resolved.

Please let us know once you have resolved the underlying errors and if there are still issues with Ark Media/Ark Editor we can then look into fixing them as well.

Thanks,

Paul

Attachments (4)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 2
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi folks, you should be more precise on the error you faced, i cannot get ride of them if i have no information, our site is clean, we have a lot of optimisation process, so perhaps it could be nice for you to disable them : Jch optimize, Scriptmerge, Script down

we have NO error in console in chrome,

i will try again to resize the image,

thanks,

 

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 3
Paul C Accepted Answer Pending Moderation
Support
0
Votes
Undo

Hi folamour,

We just tried again in Chrome and got the same error (see attached screenshot of the console).

You need to check the console when the Ark Media window pops up, not in the article view (which doesn't have the error).

If you are able to do this and replicate the error, could you then, turn off your 3rd party extensions that you mentioned above, clear your Joomla & browser cache and try again. If the error still exists then it may be an error with Ark Media. If the error is no longer there, then there is most likely a conflict between Ark Media and one of the 3rd party extensions.

Let us know how you get on.

Thanks,

Paul

Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 4
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

Hi paul, i did my way trougth chrome console and was able to saw the error, its related to mootools core,

and... they are all enabled, motools and motools more, so i'll dont know what is this error,

i have disabled :

- JCH Optmize, Asynch & Defer, Scriptmerge, Scriptdown, CDN, and jot cache

the most important issue to me (i was able to resize image) the most important is the interlign my first case, as andrew told me it was just a question of CSS class, and of course the hyperlink issue, we cannot write article without that 2 elements,

Thanks a lot & sweet week end,

guillaume,

 

 

 

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 5
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi just for information (screen shot attached) the error seem throw by CKeditor (wtf ? its JCK ?), also all the image as error 500 that is not normal, file are 664

thanks,

guillaume,

 

Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 6
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi just for information (screen shot attached) the error seem throw by CKeditor (wtf ? its JCK ?), also all the image as error 500 that is not normal, file are 664

thanks,

guillaume,

 

Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 7
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi just for information (screen shot attached) the error seem throw by CKeditor (wtf ? its JCK ?), also all the image as error 500 that is not normal, file are 664

thanks,

guillaume,

 

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 8
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

ok, i disabled CK editor but error still here, its one of your product no ?

thanks,

guillaume,

 

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 9
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi support, it seem all the issue is solved, have you done something ?

many thanks,

guillaume

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 10
Paul C Accepted Answer Pending Moderation
Support
0
Votes
Undo

Hi guillaume,

I spent some time digging into the issue and have learned the following:

Firstly, the error is still present for us, so I assume that you have switched your extensions back on. (The reason the error may have delayed being fixed for you is because your cache took time to auto-clear after you switched the extensions off the first time).

So the issue is with the JA3 cache extension and I'll explain why. The error being thrown is:

Uncaught TypeError: can't access property "id", placeholder is null

Now, if we follow where this error is triggered we are directed to a piece of JA3 code (see attached screenshot). What this script does is looks for an element on the page called "module-status", when it doesn't find that, it then looks for a page element called "menu". At this point it assumes that this element always exists on the page. The element in question is Joomla's main menu (see attached) which usually does exist. However, in pop up windows (like Ark Media) the top menu isn't loaded to maximise the space in the window. Because the code incorrectly assumes the menu is on the page it then creates errors because it tries to function with a page element that doesn't exist.

The solution here is for JA to update their script to check whether the menu is actually even present on the page.

Additionally, if you go to Joomla's default media manager (.fr/administrator/index.php?option=com_media) the same error is thrown. In this case the menu hasn't finished loading onto the page when the code is executed, so it fails again. At this point JA might wanna have a good look at the code to see what is really going on here because it triggers in multiple places (like creating a new menu and then selecting the menu-type modal pop up also triggers the error.

Feel free to send them this information to help get that error resolved. Once this is addressed we can then continue to see if Ark Media still has an issue on your site or if it is all fixed because of the error in the JA3 code.

Thanks,

Paul

Attachments (2)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 11
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi Paul, first of all, thanks you a lot for your hard work, you have done exactly that a previous support (seem to have done) 5 year ago, to fit our editor with our site.

i well understood the issue in T3 module, i will perhpas contact joomlart, as we have template support contract, any way with your excellent work you fixed the issue (screen shot attached) i created a new directory to have less images, and the thumbail is well show,

So its a luxury environment who is back to us, editor work, hyperlink work, and image preview and sizing work !

i was wondering my issue was not took in consideration, but you have done the job,

i hope to dont borry you before 5 years ; ))))))))

I'll keep you updated if i contact joomlart,

you know i'll tested other joomla editor to know if i can have a work around, but ark editor is the only one with feature like armedia.

thanks

guillaume,

 

Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 12
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

hi Paul, first of all, thanks you a lot for your hard work, you have done exactly that a previous support (seem to have done) 5 year ago, to fit our editor with our site.

i well understood the issue in T3 module, i will perpaps contact joomlart, as we have template support contract, any way with your excellent work you fixed the issue (screen shot attached) i created a new directory to have less images, and the thumbail is well show,

So its a luxury environment who is back to us, editor work, hyperlink work, and image preview and sizing work !

i was wondering my issue was not took in consideration, but you have done the job,

i hope to dont borry you before 5 years ; ))))))))

I'll keep you updated if i contact joomlart,

you know i'll tested other joomla editor to know if i can have a work around, but ark editor is the only one with feature like armedia.

thanks

guillaume,

 

Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 13
Paul C Accepted Answer Pending Moderation
Support
0
Votes
Undo

Hi guillaume,

Thank you very much for the positive feedback it really is appreciated. We're glad your system is now functioning as you expect!

If you still need support from us (before another 5 years time!) Feel free to open another support ticket and let us know if you're successful with JA support.

We'd love a short review from you if you have a moment to leave us some feedback on our support on our main facebook page: https://www.facebook.com/pg/webx.uk/reviews

Thanks!

Paul

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 14
folamour Accepted Answer Pending Moderation
Subscriber
0
Votes
Undo

no prob Paul, i will do the review because i'm really happy by the work done,

all the best,

guillaume,

 

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 15
Paul C Accepted Answer Pending Moderation
Support
0
Votes
Undo

Why thank you very much!

Have a great week.

Paul

Comment
There are no comments made yet.
  1. more than a month ago
  2. Ark Editor
  3. # 16
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Official support hour: Monday - Friday / 09:00 to 17:00 (GMT). Our local time is: 14:35:29

 One topic per thread. Please use different threads for different topics.  Please see: forums conduct.

WebxSolution Ltd and this site is not affiliated with or endorsed by The Joomla! Project™. Any products and services provided through this site are not supported or warrantied by The Joomla! Project or Open Source Matters, Inc. Use of the Joomla!® name, symbol, logo and related trademarks is permitted under a limited license granted by Open Source Matters, Inc.

Copyright © 2009 - 2018 WebxSolution Ltd
Powered by JoomlaWired

Cron Job Starts